List Management Impairment due to AWS Impact

Incident Report for IntelePeer StatusPage

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:34 EDT

Identified

The issue has been identified and a fix is being implemented by AWS.
Posted Oct 20, 2025 - 17:46 EDT

Investigating

We are currently investigating.
Intermittent failures could be experienced but not expected.
Posted Oct 20, 2025 - 12:10 EDT
This incident affected: Communications Automation Platform (CAP) (List Management).