Chicago Switch

Incident Report for IntelePeer StatusPage

Update

We are continuing to investigate this issue.
Posted Mar 27, 2026 - 11:29 EDT

Investigating

We are currently investigating an intermittent header issue impacting a subset of calls. The issue is not widespread, and teams are actively working to identify the root cause and implement a resolution. Updates will be provided as more information becomes available.
Posted Mar 27, 2026 - 11:29 EDT
This incident affects: Voice Services (Chicago Switch).