support@intelepeer.com email is currently experiencing degradation due to an event with mimecast software.
Incident Report for IntelePeer StatusPage
Resolved
This incident has been resolved.
Posted Sep 14, 2023 - 17:04 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 14, 2023 - 16:34 EDT
Investigating
Due to an issue that we are experiencing with our support@intelepeer email address that uses mimecast software,
We are asking our customers to call into our Support line, 866-780-8639, for any urgent matters.
Thank you for your patience, while we work to resolve this.
Posted Sep 14, 2023 - 16:13 EDT
This incident affected: IntelePeer.com.