Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 21, 2025 - 20:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 08, 2025 - 16:42 EDT
Scheduled
Upcoming scheduled maintenance notice
Release includes the following:
• Improvements and fixes: Bug fixes and enhancements for a smoother experience in the Voice Services Portal.
• Users can now expect a more seamless interaction with the portal, resulting in increased efficiency and usability.
• Improvements and fixes: This update includes bug fixes and enhancements to the internal reporting system associated with the Insights View. These changes aim to improve the accuracy and usability of data insights for better decision-making.
• Improvements and fixes: Bug fixes and enhancements related user roles in List Management. Some brief routing adjustments may occur during the maintenance window.
No planned service impact during this activity.
Voice Services Portal, Insights View, List Management