Important Notice for IntelePeer Voice TLS Certificate on August 27th, 2026 - New Date Requirement

Scheduled for Aug 27, 20:00 EDT  -  Aug 28, 04:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 14, 2026 - 10:12 EDT

Scheduled

Message:

To ensure uninterrupted service, we are notifying you of the annual IntelePeer Voice TLS certificate update. The current certificate will expire on August 30, 2026. We ask that all voice customers using the existing certificate load the new certificate on August 27 at 6:00 PM MT.

This year’s certificate chain is now available for download through the Voice Services Portal at https://customer.intelepeer.com/.

To access it:

Log in to your account.
Navigate to Help & Support.
Select Download TLS Certificate.

If you encounter any issues, please reach out to us at support@intelepeer.com.

We understand that applying this change may require additional effort on your side, and our team is ready to assist as needed.

If there are any configuration challenges with the new certificate, we recommend temporarily setting the transport service type to TCP until resolved.

We also encourage preloading the new TLS certificate on any supporting platforms ahead of the scheduled change date whenever possible.

Thank you for your partnership.


IntelePeer Operations
Posted Aug 14, 2026 - 10:06 EDT
This scheduled maintenance affects: Voice Services (Chicago Switch, Dallas Switch, Denver Switch).